
 
Class Templates - Administration resources for Teachers, Trainers and Instructors                                     www.class-templates.com 

 

ATT_EXCEL_002-Course_Attendance_Template_INSTRUCTIONS Last amended: 20/11/2009 Amended by: Chris / class-templates.com 

 

COURSE ATTENDANCE TEMPLATE: 

File Name: ATT_EXCEL_002-Course_Attendance_Template 

File Type: 
 
Microsoft Excel Template (.xlt) 

Application: Created using Microsoft Excel 2003 

 
Purpose of Template: 
 
This course attendance tracking template allows the attendance of up to 30 students to be tracked over a 
series of up to10 lessons. 
 
Max. Nº Students:  30 
Max. Nº Lessons:  10 
 
Hard copy Lesson Attendance Sheets can be printed for each lesson. 
 
Graphical charts monitor attendance levels by course, lesson and by student. 
 
Data entry is kept to a minimum and buttons make this template easy to navigate around. 
 
 
Instructions for Use: 
  
1 Open the Course Attendance Template 
 
If this is the first Excel template that you have downloaded from class-templates.com I recommend that you 
read the following help and advice. 
 
http://www.class-templates.com/excel-templates.html 
 
 
The spreadsheet that opens from the Course Attendance Template is automatically named 
ATT_EXCEL_002-Course_Attendance_Template1. 
 
The Course Details worksheet is displayed. 
 
Start by saving the spreadsheet with a new name and saving it in a safe location. 
 
 
For tips and advice on saving and naming files follow the link below. 
 
http://www.class-templates.com/save-your-templates.html 
 
 
2 Configure the Template for your Course 
 
When the Course Attendance template is opened the Course Details worksheet is displayed (see Fig.1 – 
Course Details worksheet).  
 
The Course Details worksheet acts as a hub page, allowing easy access to each worksheet and cell within 
the Course Attendance spreadsheet where you will be required to enter information. 
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Fig.1 - Course Details worksheet:  

 
 

 

Start configuring the open spreadsheet for your course by entering Course Details. 
 
 
2.a Enter Course Details: 
 
Enter the following Course Details into cells B1, B2, B3 and B4 on the Course Details worksheet; 
 

• Course Name 

• Level* 

• Group Name 

• Course Plan Reference 
 
Overtype and replace the default text. 
 
The Course Details that you enter here will appear on all Attendance Records. 
 
 
2.b Enter Lesson Details: 
 
The Course Schedule section is where the details of each lesson that make up the course are entered.  
 
A maximum of 10 lessons can be entered.  
 
Each lesson is numbered 1 through to 10. 
 
I recommend that you read more about Course Planning before completing the Course Schedule. Follow the 
link below for useful advice that will allow you to plan your course effectively. 
 
http://www.class-templates.com/curriculum-planning.html 
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Enter the following information for each lesson in the Course Schedule section on the Course Details 
worksheet; 
 

• Date (default date format dd/mm/yyyy must be used) 

• Time 

• Duration 

• Location* 

• Teacher* 

• Lesson Plan Ref 
 
* To amend default drop-down options see section 5 - Amending Drop-down list options 
 
The Lesson Details that you enter in the Course Schedule section will appear on the corresponding lesson 
Attendance Record. 
 
 
2.c Enter Student Names: 

 

Click on the Student Details button on the Course Details worksheet to enter the names of the students that 
will be enrolled on the course.  
 
The Student Details worksheet is displayed. 
 
Fig. 2 – Student Details worksheet: 

 
 
Enter the names of the students that are enrolled on the course into column B. 
 
Enter the name of the first student into cell B2 where the default text >> enter Student name is displayed. 
Overtype the default text.  
 
Enter the second student name into cell B3, the third into B4 and so on until you have entered the names of 
all the students that are enrolled on the course.  
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A maximum of 30 student names can be entered. 
 
All other cells on the Student Details worksheet are automatically populated when an Attendance Record is 
completed for each lesson delivered. 
 
There are a number of buttons on the Student Details worksheet that allow easy navigation to the Course 
Details worksheet and attendance charts. 
 
The Course Attendance spreadsheet is now configured for your course. 
 
Make sure that you save all your changes! 
 
3 Tracking Attendance 
 
When you have configured the spreadsheet for your course (Course Details, Course Schedule and Student 
Names entered) the spreadsheet is ready to record the attendance of each lesson. 
 
Ideally, if you have access to the Course Attendance spreadsheet at each lesson, you can record student 
attendance directly into the spreadsheet. 
 
If not, an Attendance Record for each lesson can be printed before each lesson and completed by hand. 
After the lesson the Course Attendance spreadsheet can be updated. 
 
3.a The Attendance Record 
 
The Attendance Record is where you record if a student attends a lesson or not. 
 
An Attendance Record exists for each lesson defined in the Course Schedule and can be accessed from the 
Course Details worksheet. 
 
To open the Attendance Record for a lesson, click on the Lesson Nº button to the left of the Lesson Date. 
The Attendance Record for the selected lesson is displayed. 
 
Fig 3. – Attendance Record worksheet: 
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NOTE: If a Date has not been entered for a lesson you will be prompted to enter a date before you can 
access the corresponding Attendance Record. 
 
The Course Details and Lesson Details are automatically populated using the information that has been 
entered on the Course Details worksheet. 
 
Student Names are automatically populated using the student names that have been entered on the Student 
Details worksheet. 
 
If the Course Details, Lesson Details or Student Names need to be amended or have not been entered, use 
the blue text links to navigate to the corresponding cells on the Course Details and Student Details 
worksheets where the information can be entered or amended. 
 
NOTE: Amendments to Course Details and Student Names will be applied to all Attendance Records.  
 
Complete an Attendance Record for each lesson when it is delivered. 
 
 
3.b Recording Attendance 
 
On the Attendance Record under the Attended? column header, select the relevant option from the drop-
down list for each student.  
 
The default options available are PR (Present) and AB (Absent). 
 
If a student is not present ensure that AB is selected. Do not leave blank. Attendance information entered 
into each Attendance Record is used to plot the Attendance Charts. 
 
There is space on each Attendance Record to make comments about each student. For example you may 
want to note why a student is absent or if a student arrives late or leaves early. 
 
There is also space to note any Incidents, Comments or Observations about the lesson in general. For 
example you may want to note if the lesson was interrupted by a fire drill or if certain equipment or materials 
were not available that would normally be used.  
 
When you have finished recording student attendance for a lesson, return to the Course Details worksheet 
by clicking on any of the Course Details or Lesson Details blue text links. 
 
You will notice that the Attendance Figures on the Course Details worksheet have been updated.  
 
The Attendance Charts will also update each time when an Attendance Record is completed or updated. 
 
 
4 Attendance Charts 
 
There are 6 attendance charts setup within the Course Attendance Template. They allow attendance to be 
tracked at a course level, at an individual lesson level and by student. 
 
Each attendance chart is automatically updated when an Attendance Record is completed or amended. 
 
There are two buttons on each chart to allow easy navigation to the Course Details and Student Details 
worksheets. These buttons do not appear on hard copy print outs. 
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4.a Course Attendance Chart 
 
The Course Attendance chart plots as a pie chart the percentage of enrolled students that have attended 
delivered lessons (lessons where an Attendance Record has been completed). It provides an overall picture 
of how well the course has been attended to date. 
 
For example, if lessons 1 and 2 have been delivered and all enrolled students attend, the Course Attendance 
Chart would show a 100% course attendance. However, if only half of the enrolled students attend lesson 3, 
the Course Attendance Chart would show an 83% course attendance. 
 
Fig. 4 – Course Attendance chart: 

Course Attendance 

as % of Enrolled Students

83

17

Course Attendance:

Course Absence:

 
 
 
4.b Lesson Attendance Chart 
 
The Lesson Attendance Chart plots as a bar chart the number of students that attend each lesson of the 
course. 
 
Each lesson is displayed on the x-axis of the chart and the number of students attending each lesson is 
plotted on the y-axis. By default the scale of the x-axis is set to the maximum number of 10 lessons. 
Likewise, the scale of the y-axis is set to the maximum number of 30 students. 
 
Fig. 5 – Lesson Attendance chart: 
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4.c Lesson Attendance % Chart 
 
The Lesson Attendance % chart plots as a bar chart the percentage of enrolled students attending each 
lesson. It provides at a glance how well each lesson is attended. 
 
For example if a course has 10 enrolled students and all 10 attend a lesson, the Lesson Attendance % chart 
will show an attendance of 100% for those lessons. However, if only 5 students attend a lesson the chart will 
show an attendance of 50% for that lesson. 
 
By default the scale of the x-axis is set to the maximum number of 10 lessons. 
 
Fig. 6 – Lesson Attendance % chart 
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4.d Student Attendance Chart 
 
The Student Attendance chart plots as a bar chart the number of lessons each student has attended. It 
provides at a glance how many lessons an individual student has attended over the course. 
 
By default the scale of the x-axis is set to the maximum number of 30 students. Likewise, the scale of the y-
axis is set to the maximum number of 10 lessons. 
 
Fig. 7 – Student Attendance chart 
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If you would like to view which lessons a student has not attended then click on the Student Details button.  
 
The Student Details worksheet is displayed.  
 
Lessons that students do not attend are highlighted in red. 
 
 
4.e Student Attendance % Chart 
 
The Student Attendance % chart plots as a bar chart the percentage of lessons that each student has 
attended. It provides at a glance the students attendance record for the course to date. 
 
For example if a student has attended 3 out of 3 delivered lessons the chart will show that student to have an 
attendance record of 100%. However if a student attends only 2 out of 3 delivered lessons the chart will 
show that student to have an attendance record of 67%. 
 
 
Fig. 8 – Student Attendance % chart: 
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If you would like to view which lessons a student has not attended then click on the Student Details button.  
 
The Student Details worksheet is displayed.  
 
Lessons that a student does not attend are highlighted in red. 
 
 
4.f Student Absence Chart 
 
The Student Absence chart plots as a bar chart the number of lessons that a student has not attended. It 
provides at a glance a record of all students that have missed lessons. 
 
By default the scale of the x-axis is set to the maximum number of 30 students. Likewise, the scale of the y-
axis is set to the maximum number of 10 lessons. 
 

 

 

 

 

 

 

 



 
Class Templates - Administration resources for Teachers, Trainers and Instructors                                     www.class-templates.com 

 

ATT_EXCEL_002-Course_Attendance_Template_INSTRUCTIONS Last amended: 20/11/2009 Amended by: Chris / class-templates.com 

 

Fig. 9 – Student Absence chart 

Nº of Absences - by Student
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If you would like to view which lessons a student has not attended then click on the Student Details button.  
 
The Student Details worksheet is displayed.  
 
Lessons that a student does not attend are highlighted in red. 
 
 
5 Amending Drop-down list options 
 
The following instructions describe how to amend or add to the drop-down list options available in some 
cells. 
 
There are 4 drop-down lists within the Course Attendance template, each with default options entered. 
 
When you click in a cell that has a drop-down list available, a downward pointing arrow head appears to the 
right hand side of the cell. Click on the arrow head to display the drop-down list options. 
 
The table below details the drop-down lists and the options for each. 
 

Level: select >> Beginner Intermediate Advanced 

Location: select >> Location 01 Location 02 Location 03 

Teacher: select >> Teacher 01 Teacher 02  Teacher 03 

Amended? Yes No   

 
 
First establish if you wish to permanently change these drop-down options or if the changes only apply to a 
particular course. 
 
 
5.a Permanently Change Drop-down list options: 

 

If you wish your changes to apply to each course now and in the future, you will need to amend the Course 
Attendance Template file that has the .xlt file extension. 
 
To open the Course Attendance Template (.xlt file extension) right click on the Microsoft Excel Template 
icon and select Open from the menu that appears. This opens the actual template file.  
 
Check that the name of the file you are amending is ATT_EXCEL_002-Course Attendance_Template. 
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NOTE: Changes made and saved to the Course Attendance Template file (.xlt) will be permanent and be 
applied to all future spreadsheets that are opened using the .xlt file. 
 
 
5.b Change Drop-down list options for a particular course: 
 
If you want amendments to the drop-down list options to only apply to a particular course, amend the Course 
Attendance spreadsheet file that has the .xls file extension. 
 
This is the spreadsheet that is opened when the Course Attendance Template file is opened by double 
clicking on the Microsoft Excel template icon. 
 
You will probably have saved this file with the name of the course. 
 
 
5.c Amending an existing drop-down list option 
 
If you want to amend an existing drop-down list option, navigate to the Drop-down list Data worksheet. To do 
this click on the blue text link for the relevant drop-down list you wish to amend. 
 
To amend existing options simply write over the existing text with the text you want displayed. 
 
By default there are 3 pseudo locations and 3 pseudo teachers. You will probably want to amend these 
immediately. 
 
If you do not wish to use all available options simply delete the text not required. For example, you may only 
deliver lessons in two locations. If Location 03 is not relevant then simply delete the text Location 03. 
 
 
5.d Adding additional drop-down list options 
 
To add additional drop-down list options you will first need to Unprotect the Drop-down List Data worksheet. 
 
How? 
 
From the Tools menu click Protection and then click Unprotect Sheet. 
 
Tools > Protection > Unprotect Sheet 
 
In the next available cell in the same row that corresponds to the drop-down list you wish to add to, enter the 
new option text.  
 
Example: 
 
I am going to add a new Level drop-down list option called Proficient. I enter this text into cell F1 to the right 
of Advanced. 
 
We now need to ensure that this new option is available in the Level drop-down list where ever it appears in 
the spreadsheet. 
 
How? 
 
From the Insert menu click Name and then Define 
 
Insert > Name > Define 
 
The Define Name screen is displayed.  
 
Select the name of the drop-down list that you are entering a new option for. In our example we are adding 
to the Level drop-down list. 
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Click on the Refers to: selection button. 
 
The Define Name – Refers to: dialogue box is displayed. 
 
Highlight the range of cells to include in the drop-down list. Make sure that you include the new drop-down 
list option in your selection.  
 
In the example we need to expand the range of cells defined for the Level drop-down list to include Proficient 
located in cell F1. Therefore the range of cells to be included in the Level drop-down list is B1:F1. 
 

 
  
Close the Define Name – Refers to: dialogue box by clicking on the cross. 
 
On the Define Name screen click OK when you have checked that the correct range of cells has been 
selected. 
 
The drop-down list will be updated wherever it appears in the Course Attendance template. 
 
Repeat this procedure for each drop-down list that you wish to add options to. 
 
 
When you have made all the amendments or additions that you need to make to the Drop-down List Data 
worksheet, it is good practice to Protect the worksheet again. 
 
How? 
 
From the Tools menu click Protection and then click Protect Sheet. 
 
Tools > Protection > Protect Sheet 
 
 
The Protect Sheet screen is displayed. 
 
Click OK to enforce protection. 

 


